Generic filters
Exact matches only
Search in title
Search in content
Filter by Custom Post Type
Posts
Filter by Categories







[CVSS 9+]: Exploit Attempts for Apache Struts Vulnerability

What Is Happening?

Experts have detected exploit attempts for a critical vulnerability in Apache Struts 2 worldwide. This vulnerability, identified as CVE-2023-50164, enables unauthorised access to restricted files and compromises server security. It has a CVSS score of 9.8. Please refer to our recent news article for additional details about this vulnerability.

Furthermore, a proof of exploit (PoE) is available for this vulnerability, which simplifies the exploit process for attackers. The observed exploit attempts appear to follow the steps outlined in the PoE. It is important to note that experts have emphasised the ease of following the PoE, which could make the vulnerability an attractive target for many attackers.

Therefore, it is critical to promptly update Struts and stay informed about new developments in order to mitigate risks.

About the Vulnerability

The vulnerability, listed as CVE-2023-50164, affects various versions of Apache Struts, including those that are no longer supported. It has a CVSS score of 9.8 out of 10.

The implications of the vulnerability are significant, as it can lead to unauthorised access, data theft, and even a full system compromise.

Attackers can exploit the vulnerability by inputting path traversal sequences in file or directory paths, bypassing the built-in checks. This allows them to plant a web shell and gain persistent access to the server. The compromised server can execute malicious scripts, such as JSP files, as soon as the attacker requests them.

Call for Action

Apache urges users and administrators to review the Apache Security Bulletin and upgrade to Struts 2.5.33 or Struts 6.3.0.2 (or newer versions) as soon as possible.

Please note that there are no workarounds for this vulnerability. The good news is that experts indicate that upgrading to the patched versions is relatively straightforward, as they can be directly installed without any additional modifications.

Given the critical nature of the vulnerability, which could lead to a complete system compromise, the availability of a PoE, and the fact that attackers are already attempting to exploit it, it is essential to upgrade Struts urgently. It is crucial to stay informed about the situation and respond promptly to any new information that becomes available.

RECENT BLOG POSTS

PODCASTS

Cubic Lighthouse is a cybersecurity publication dedicated to demystifying security, making news actionable, providing deeper thinking about the fundamentals of security, and providing decision-makers and the community at large with the right information to make the right decisions. We will also feature more technical articles and provide personal/family security advice.

©2024 Cubic Consulting, a Smart Security Company for your Business – All Rights Reserved.